Radious rod ball problem - I think and clutch trouble still

Topics Last Day Last Week Tree View    Getting Started Formatting Troubleshooting Program Credits    New Messages Keyword Search Contact Moderators Edit Profile Administration
Model T Ford Forum: Forum 2010: Radious rod ball problem - I think and clutch trouble still
Top of pagePrevious messageNext messageBottom of page Link to this message  By John Leming on Sunday, October 24, 2010 - 06:03 pm:

My 1924 watts clutch coupe is still giving me problems when I go from low to hi - and today for the first time I experienced something new. I realize now that the grabbing, or shaking the car does when I engage the clutch happens with power off. In other words I reduce the throttle, and I can let out to high slow, or let out to high fast, either way the clutch grabs or shakes before engaging. After it does this I can ease the throttle open fast or slow and everything is fine, no slipping and Im in hi. Today that shaking caused the front end to start wobbling violently - I mean violently almost taking the wheel out of my hands. I inspected the radius ball and fount that with the cap as tight as it can go, the ball moves up and down at least 1/8 inch, and from side to side at least 1/8 inch or more. So both of these are problems and I need help! Maybe the clutch just needs to be taken up another half turn or so - It was slipping several weeks ago, and 1/2 turn on the fingers remedied that. but it still grabs or shakes a bit before being enguaged.


Top of pagePrevious messageNext messageBottom of page Link to this message  By Norman T. Kling on Sunday, October 24, 2010 - 07:08 pm:

If you have a Ford clutch, I suspect that you need to practice letting out the clutch. It works best if you slow the engine and let it out quickly, not "pop" the clutch, but not slip it either. It takes practice to get the car moving at the proper speed and get the engine to slow down as you shift from low to high.

The other problem. You need to do one or possibly two of the following things. 1. buy a new cap for your bearing. 2. File down the cap so it fits more tightly 3. Insert a piece of oiled leather between the top of the ball and the crankcase. 4. Replace the ball if it is excessively worn.


Top of pagePrevious messageNext messageBottom of page Link to this message  By John Leming on Sunday, October 24, 2010 - 07:12 pm:

Its a watts clutch - new and was slipping first time out, but now not slipping, just rough when engaged. The radius rod ball bothers me most - seems very dangerous - is this what caused this violent wheel shaking?? And i suppose the APCO kit might help - Langs has a tech tip about using a freeze plug - anyone tried that? and this ball should have no side to side movement or up and down movement - is that right??


Top of pagePrevious messageNext messageBottom of page Link to this message  By Royce Peterson on Sunday, October 24, 2010 - 07:20 pm:

The watts clutches are big trouble. We see this all the time, it is unfortunate but the only real fix is to replace the defective clutch with original type steel clutch plates to eliminate the source of trouble.

The radius rod, probably a shim can be made. Here is a picture of original shims that were sold by Western Auto. You can make something similar from a scrap piece of appropriate thickness steel or brass sheet that will solve the trouble.


Top of pagePrevious messageNext messageBottom of page Link to this message  By John Leming on Sunday, October 24, 2010 - 07:29 pm:

I think it is the clutch and not me, I dont have this problem driving my 25 truck, but is is original ford steel clutch plates. The watts just never has been right. But again, it is not slipping after it takes hold, its grabbing or just slipping for a second or two while it takes hold. After that, when you add power to the car, it is great As for the ball - are you guys telling me - no movement at all side to side - up or down? if so, yes, I can no doubt make a shim and fit it that way. the shims in the photo accomplish what I guess Langs is saying in using a freeze plug between the ball and the crankcase???


Top of pagePrevious messageNext messageBottom of page Link to this message  By Royce Peterson on Sunday, October 24, 2010 - 07:45 pm:

There should be zero play in the ball, either side to side or up and down. You should grease it every couple of years so that free rotation is ensured and wear is minimized.


Top of pagePrevious messageNext messageBottom of page Link to this message  By Lee Crenshaw on Tuesday, October 26, 2010 - 12:24 pm:

John, did you install the Watt's clutch? I suspect that the Ford clutch plates had worn grooves in the clutch hub and the present clutch is dragging on that uneven surface and not engaging as smoothly as it should. The grooves need to be smoothed out in some fashion. (JBWeld?)


Top of pagePrevious messageNext messageBottom of page Link to this message  By Gary Mittrucker on Tuesday, October 26, 2010 - 08:42 pm:

We have an apco spring loaded ball cap for the front radius rod. Works great and holds the radius rod tight. Make sure nothing in the front axle is worn out or loose. Also check to see if you have proper alignment. Like Lee said you might have grooves in your brake drum making the clutch engage rough.

Thanks,
Stephen


Posting is currently disabled in this topic. Contact your discussion moderator for more information.
Topics Last Day Last Week Tree View    Getting Started Formatting Troubleshooting Program Credits    New Messages Keyword Search Contact Moderators Edit Profile Administration