OT - electrical strip connectors

Topics Last Day Last Week Tree View    Getting Started Formatting Troubleshooting Program Credits    New Messages Keyword Search Contact Moderators Edit Profile Administration
Model T Ford Forum: Forum 2011: OT - electrical strip connectors
Top of pagePrevious messageNext messageBottom of page Link to this message  By Harold Schwendeman on Wednesday, December 28, 2011 - 02:29 pm:

Steve Jelf just posted a photo of the new strip connector he mounted over his workbench to eliminate "cord clutter":

I am a complete "zero" when it comes to knowledge concerning anything electrical, so that's why I am asking about such equipment.

Some years ago, I purchased a couple of inexpensive "6-outlet strip connectors" (not even sure if that is proper terminology) and accordingly, plugged in several different "appliances". Over a period of time, un-noticed by anybody, this tan colored plastic "cheapo" strip connector actually began to show what appeared to be dark brown "burn marks" which I found to "disturbing", to say the least. As I recall, we had the heater for the waterbed, headboard type reading lamps, alarm clock radio, etc. plugged into the strip connector. I began watching the thing more carefully but never did detect any real heat, or even warmth from the strip connector, however, it worried me and so I threw it away and replaced it from a more heavy-duty looking strip connector that was made of all metal instead of plastic. I can't recall the numbers, however I do recall distinctly that both strip connectors, the plastic one that I threw away, and the all-metal one that I replaced it with had the SAME capacity rating. (???)

Since this experience, I have always tried to buy all-metal strip connectors, however, I really would like to know if what I'm trying to explain here is a valid "SAFETY ISSUE".

Again, having very little knowledge of such things electrical, it is my opinion that most of these cheap looking 6-outlet plastic strip connectors (some with built-in surge protection) are designed with the idea that they will be used mostly for household computers, printers, copy machines, etc, etc, but should never be used for high current-drawing appliances like 1500 watt electric heaters and such.

I really think that there is a safety issue here. Could somebody tell me if what I am saying makes any sense or not? Thank you,.....harold


Top of pagePrevious messageNext messageBottom of page Link to this message  By Dennis Seth - Ohio on Wednesday, December 28, 2011 - 02:51 pm:

Harold,

You are correct in thinking there is a safety issue. The safest thing you can do is have the house wiring up graded or inspected by a qulified electrician. Think about what you are doing...you are taking 6 outlets and running them through a single cord when you use one of those strips.


Top of pagePrevious messageNext messageBottom of page Link to this message  By Steve Jelf, Parkerfield, KS on Wednesday, December 28, 2011 - 03:12 pm:

It all depends on how much of what is plugged into it and working at the same time. Example: if I have two little hand grinders plugged into it with different attachments, obviously I'm not running them both at the same time, so no harm done. On the other hand, if I plug in a couple of shop lights, and a heater, and a shop vac, and run them all at once, I'm asking for trouble. Drawing more current than the thing is rated for will get it hot. Enough more, and it will get really hot.


Top of pagePrevious messageNext messageBottom of page Link to this message  By Floyd Voie - Chehalis, Washington on Wednesday, December 28, 2011 - 04:27 pm:

Harold,
Steve & Dennis have given good advise. Add up the wattage of everything you have plugged in to it and see what the total is. Most likely the waterbed heater is on a themostat and that heater is no doubt your largest load and does get your strip warm when it kicks in. Perhaps the heater could be plugged in elsewhere?
Safety First!
Happy New Year!
Floyd


Top of pagePrevious messageNext messageBottom of page Link to this message  By Floyd Voie - Chehalis, Washington on Wednesday, December 28, 2011 - 04:29 pm:

Harold.....
p.s.
Got the wood today for the cart.
Floyd


Top of pagePrevious messageNext messageBottom of page Link to this message  By Gary H. White, Sheridan, MI on Wednesday, December 28, 2011 - 04:47 pm:

Make sure your power strip has a circuit breaker and you should be OK. BTW I also have outlets mounted on the front of my work bench for the portable tools (drills, sanders, soldering iron, etc.). Makes things easier and neater as I am not knocking things over with the cords.


Top of pagePrevious messageNext messageBottom of page Link to this message  By Ken Todd on Friday, December 30, 2011 - 11:06 am:

A good rule to follow is to load up any outlet or power bar to only 80% of it's wattage rating, especially if it's a long term load.


Posting is currently disabled in this topic. Contact your discussion moderator for more information.
Topics Last Day Last Week Tree View    Getting Started Formatting Troubleshooting Program Credits    New Messages Keyword Search Contact Moderators Edit Profile Administration