Old Photo - Geta Horse !

Topics Last Day Last Week Tree View    Getting Started Formatting Troubleshooting Program Credits    New Messages Keyword Search Contact Moderators Edit Profile Administration
Model T Ford Forum: Forum 2013: Old Photo - Geta Horse !
Top of pagePrevious messageNext messageBottom of page Link to this message  By Jay - In Northern California on Friday, July 19, 2013 - 10:19 am:


Top of pagePrevious messageNext messageBottom of page Link to this message  By Jim york on Friday, July 19, 2013 - 11:30 am:

It doesn't look like a Ford, but it is an interesting speedster. What kind is it? You do what you have to do or is it staged? Jim


Top of pagePrevious messageNext messageBottom of page Link to this message  By Mark Gregush Portland Oregon on Friday, July 19, 2013 - 11:50 am:

It's a Chevrolet.


Top of pagePrevious messageNext messageBottom of page Link to this message  By Henry Petrino in Modesto, CA on Friday, July 19, 2013 - 11:54 am:

Well Mark, that explains why he's pulling it. :-)


Top of pagePrevious messageNext messageBottom of page Link to this message  By Mark Gregush Portland Oregon on Friday, July 19, 2013 - 12:04 pm:

Ya, he forgot to put oil in the valve spring gallery and the valves seized up!


Top of pagePrevious messageNext messageBottom of page Link to this message  By Dennis Henrichs on Friday, July 19, 2013 - 05:03 pm:

Even the horse refused to pull a "Chebby" and walked off!


Posting is currently disabled in this topic. Contact your discussion moderator for more information.
Topics Last Day Last Week Tree View    Getting Started Formatting Troubleshooting Program Credits    New Messages Keyword Search Contact Moderators Edit Profile Administration