Just joined the busted low gear drum club!

Topics Last Day Last Week Tree View    Getting Started Formatting Troubleshooting Program Credits    New Messages Keyword Search Contact Moderators Edit Profile Administration
Model T Ford Forum: Forum 2015: Just joined the busted low gear drum club!
Top of pagePrevious messageNext messageBottom of page Link to this message  By Warwick Landy Traralgon Australia on Sunday, November 15, 2015 - 10:04 pm:

Was on a week long tour in the T last week. On the first day I drove to the morning T stop. Went to leave and had no low gear. Nipped up the band, inspected the drum and got enough low to get me home. In the course of the week I nipped up what was left of the band a number of times and was able to complete the tour. I suspected it had been my fault. I burnt the band as the pedal got caught on the floorboard and did not come out all the way. Band must have stayed on the drum frying it and possibly causing the drum to crack??? anyway, cover is off, engine & trans ready for removal and disassembly. Will add some pictures soon.


Top of pagePrevious messageNext messageBottom of page Link to this message  By Erik Barrett in Auburn Ca. on Monday, November 16, 2015 - 01:35 am:

While you are at it, replace the low speed notch and pedal support in the hogshead. When these are worn out, as most are, it is impossible to get a proper low band adjustment. This leads to slipping the band, overheating the drum, and all of the symptoms and results you describe. I have a car in the shop right now with a collapsed low drum and resultant damage from the same scenario.


Posting is currently disabled in this topic. Contact your discussion moderator for more information.
Topics Last Day Last Week Tree View    Getting Started Formatting Troubleshooting Program Credits    New Messages Keyword Search Contact Moderators Edit Profile Administration