Rube horn

Topics Last Day Last Week Tree View    Getting Started Formatting Troubleshooting Program Credits    New Messages Keyword Search Contact Moderators Edit Profile Administration
Model T Ford Forum: Forum 2016: Rube horn
Top of pagePrevious messageNext messageBottom of page Link to this message  By John Eaton on Wednesday, January 27, 2016 - 10:12 pm:

The Rube horn on my 1913 won't sound because the brass wound air pipe leaks. Horn works well when I place new bulb on horn. How can I seal this hose rather than buy new for $20 per foot? Thanks for the help. Regards, John


Top of pagePrevious messageNext messageBottom of page Link to this message  By Brad Van Meter on Wednesday, January 27, 2016 - 10:24 pm:

Go to the hardware store and purchase some vinyl braid hose and slip it inside the brass hose. Works perfectly.


Top of pagePrevious messageNext messageBottom of page Link to this message  By John Eaton on Wednesday, January 27, 2016 - 10:45 pm:

Thanks Brad, How do I seal it at each end or is that necessary?


Top of pagePrevious messageNext messageBottom of page Link to this message  By John Eaton on Thursday, January 28, 2016 - 07:49 pm:

Thanks Brad! That tip works very well. I used per water pipe and small "o" rings


Top of pagePrevious messageNext messageBottom of page Link to this message  By Brad Van Meter on Friday, January 29, 2016 - 10:10 am:

You're welcome!


Add a Message


This is a private posting area. Only registered users and moderators may post messages here.
Username:  
Password:

Topics Last Day Last Week Tree View    Getting Started Formatting Troubleshooting Program Credits    New Messages Keyword Search Contact Moderators Edit Profile Administration