Difficulty loging in and finding site/forum

Topics Last Day Last Week Tree View    Getting Started Formatting Troubleshooting Program Credits    New Messages Keyword Search Contact Moderators Edit Profile Administration
Model T Ford Forum: Forum 2016: Difficulty loging in and finding site/forum
Top of pagePrevious messageNext messageBottom of page Link to this message  By George John Drobnock on Wednesday, March 09, 2016 - 12:50 pm:

An observation ---

It may be my browser, it may be my provider, it may be my computer, and it may be me --

I am having difficulty through the search engine finding either MTFCA or the site spelled out. No I do not have it bookmarked.


Top of pagePrevious messageNext messageBottom of page Link to this message  By Dave Dufault on Wednesday, March 09, 2016 - 01:04 pm:

Yes, the Gremlins are running amok and causing all sorts of problems. Chris has worked long and hard to bring these pages back, and I believe he will soon have other glitches repaired/remedied. In the meantime, as long as you are here and want to get to the other features of the MTFCA site, use your back arrow to get to the first discussion page, then near the top of the page, click on MTFCA Home (a live link) and that will bring you to the Home page wherein you can navigate to the other areas that you are trying to locate.


Top of pagePrevious messageNext messageBottom of page Link to this message  By Jesse L. Ashcraft on Saturday, March 12, 2016 - 12:41 pm:

Has there ever been any support for putting all photos on one monthly thread? For instance: "March photos."

That might go a long way cleaning up the front page for easier navigation of current topics.


Add a Message


This is a private posting area. Only registered users and moderators may post messages here.
Username:  
Password:

Topics Last Day Last Week Tree View    Getting Started Formatting Troubleshooting Program Credits    New Messages Keyword Search Contact Moderators Edit Profile Administration