Brian Mettling - Dayton OH Model A

Topics Last Day Last Week Tree View    Getting Started Formatting Troubleshooting Program Credits    New Messages Keyword Search Contact Moderators Edit Profile Administration
Model T Ford Forum: Forum 2016: Brian Mettling - Dayton OH Model A
Top of pagePrevious messageNext messageBottom of page Link to this message  By Hal Schedler, Sacramento on Monday, April 25, 2016 - 01:45 pm:

Your "A" depends on the water pump. Check that first and then see about the radiator. Also check your timing, though the way is sounds it's not that. IMHO


Top of pagePrevious messageNext messageBottom of page Link to this message  By Ron in Central Massachusetts on Monday, April 25, 2016 - 02:54 pm:

Brian,

You mention in your original post that the radiator was "leaking like crazy" out the bottom. I think that is the issue - she leaked, got low and then boiled.


Top of pagePrevious messageNext messageBottom of page Link to this message  By Brian Mettling - Dayton OH on Monday, April 25, 2016 - 03:07 pm:

thanks guys. I'm going to tear it all down, methinks that I may have a loose connection and that it all leaked out too. Might have worked loose on the drive over


Top of pagePrevious messageNext messageBottom of page Link to this message  By Ron in Central Massachusetts on Monday, April 25, 2016 - 03:41 pm:

Let us know what you find.


Top of pagePrevious messageNext messageBottom of page Link to this message  By David Dewey, N. California on Monday, April 25, 2016 - 06:00 pm:

So where's the start of this thread?? It seems to just start in the middle of things.


Top of pagePrevious messageNext messageBottom of page Link to this message  By Brian Mettling - Dayton OH on Monday, April 25, 2016 - 08:15 pm:

I accidentally posted in classifieds. I checked it out and the lower radiator inlet area had a few broken fins and drained the coolant completely. Had no idea it was even bad, no previous leaks. Also believe I fried the manifold and head gasket but didn't seize the engine...but it sure smells awful. That will be a weekend project...


Top of pagePrevious messageNext messageBottom of page Link to this message  By David Dewey, N. California on Monday, April 25, 2016 - 11:27 pm:

Ah, OK! I do hope your engine's OK.


Top of pagePrevious messageNext messageBottom of page Link to this message  By Ron in Central Massachusetts on Tuesday, April 26, 2016 - 06:50 am:

Brian - think you dodged a major bullet. Might be time for a new radiator. Berg's makes both T and A replacements and they're a really great product.


Add a Message


This is a private posting area. Only registered users and moderators may post messages here.
Username:  
Password:

Topics Last Day Last Week Tree View    Getting Started Formatting Troubleshooting Program Credits    New Messages Keyword Search Contact Moderators Edit Profile Administration