Engine install

Topics Last Day Last Week Tree View    Getting Started Formatting Troubleshooting Program Credits    New Messages Keyword Search Contact Moderators Edit Profile Administration
Model T Ford Forum: Forum 2016: Engine install
Top of pagePrevious messageNext messageBottom of page Link to this message  By Jim Eubanks, Powell, TN on Saturday, May 14, 2016 - 05:34 pm:

I just installed the engine in my 26 this afternoon. Was the easiest job I have ever had and did it by myself. Had the car up on stands in the front, One back wheel just off the floor, Greased top of the frame on both side and was able to move it by hand from underneath, aligned the u joint with a 15/16" wrench and wham, it slid together.


Top of pagePrevious messageNext messageBottom of page Link to this message  By Fred Dimock, Newfields NH, USA on Saturday, May 14, 2016 - 05:38 pm:

Great job Jim!

I found the same thing when I slid the motor in my 19 for the second time.
I learned that you don't bolt the universal housing until after you put the motor mount bolts in place.


Top of pagePrevious messageNext messageBottom of page Link to this message  By Eric Sole - Castelldefels (Spain) on Saturday, May 14, 2016 - 05:42 pm:

Encouraging news! I hope do way the same thing soon. :-)


Top of pagePrevious messageNext messageBottom of page Link to this message  By Eric Sole - Castelldefels (Spain) on Saturday, May 14, 2016 - 05:53 pm:

I hope to say... :s


Add a Message


This is a private posting area. Only registered users and moderators may post messages here.
Username:  
Password:

Topics Last Day Last Week Tree View    Getting Started Formatting Troubleshooting Program Credits    New Messages Keyword Search Contact Moderators Edit Profile Administration