1926 Touring 21" rims...

Topics Last Day Last Week Tree View    Getting Started Formatting Troubleshooting Program Credits    New Messages Keyword Search Contact Moderators Edit Profile Administration
Model T Ford Forum: Forum 2016: 1926 Touring 21" rims...
Top of pagePrevious messageNext messageBottom of page Link to this message  By Michael Warren- Huntington, VT on Sunday, May 15, 2016 - 09:38 pm:

I have been having a ton of issues getting the rear end of my touring rebuilt. I decided to take a break from that and do something different for a bit to take my mind off from the frustration...

I disassembled the wheels, removed the old tires, and am looking the wheels over to make sure they look alright before I blast them and paint them.

All four rims are the split rim style and NONE of them had any sort of nut or bolt securing them at the split... Two of them look like they have one type of fastener and two look like they have another type of fastener. One of the rims looks like the metal broke where the fastener goes...(I put a piece of white paper so you could see it easier.

Does anyone have suggestions on what I should do with these rims? Should I just try to get new fasteners for them? Are the rims Junk?






Top of pagePrevious messageNext messageBottom of page Link to this message  By John Zibell, Huntsville, AL on Sunday, May 15, 2016 - 10:23 pm:

If other wise solid, you could make latches. Other options are to find good used, and if necessary buy new http://www.americanvintagerims.com/


Top of pagePrevious messageNext messageBottom of page Link to this message  By Jack Daron - Brownsburg IN on Sunday, May 15, 2016 - 10:29 pm:

All your pictures are showing the bottom of latch area.Do you have any taken showing the top? I'd guess they are repairable,if the top is at least there.


Top of pagePrevious messageNext messageBottom of page Link to this message  By Michael Warren- Huntington, VT on Sunday, May 15, 2016 - 10:59 pm:

Only two of the rims have a "latch" on the top portion. The other two are missing them completely...


Top of pagePrevious messageNext messageBottom of page Link to this message  By Michael Warren- Huntington, VT on Wednesday, August 03, 2016 - 09:51 pm:

Got 4 new rims and not sure if I should paint them or leave them the way they are. I believe that they are plated already but there is a blemish spot in the exact same spot on all 4 wheels where they are welded together. Any thoughts on what I should do? Paint them or mount them as they are?


Top of pagePrevious messageNext messageBottom of page Link to this message  By John Zibell, Huntsville, AL on Wednesday, August 03, 2016 - 10:57 pm:

It looks like paint could be your friend. Also once painted the new rims may be more resistant to oxidation then if left only plated. Granted once mounted on the car only a small portion would be visible, but the paint protection could be a good thing. I'm hoping you have a 5th rim good enough for a spare.


Add a Message


This is a private posting area. Only registered users and moderators may post messages here.
Username:  
Password:

Topics Last Day Last Week Tree View    Getting Started Formatting Troubleshooting Program Credits    New Messages Keyword Search Contact Moderators Edit Profile Administration