Well I've done it now....

Topics Last Day Last Week Tree View    Getting Started Formatting Troubleshooting Program Credits    New Messages Keyword Search Contact Moderators Edit Profile Administration
Model T Ford Forum: Forum 2016: Well I've done it now....
Top of pagePrevious messageNext messageBottom of page Link to this message  By William L Vanderburg on Friday, June 10, 2016 - 05:11 pm:

I've probably voided the warranty, but I've had trouble with my Becker alternator for over a year. I contacted Daryl at the time to send to him but life decided to get in the way.

I recently emailed him about sending it to him but he never responded

Soooo.... I took the alt housing apart. My initial problem was the alternator stopped charging and the battery post would rotate in the housing. Daryl said the nut was probably lose on the inside.

Well, the nut was completely gone as in Not There. So I replaced it. Took it back out to the car, put it back on and it was charging like there was no tomorrow. This was the first alternator I've ever taken apart.

I'll recheck it tomorrow and see if it still works.


Top of pagePrevious messageNext messageBottom of page Link to this message  By John T. Tannehill III, Hot Coffee, MS on Friday, June 10, 2016 - 06:30 pm:

Great, I've tried to contact him also with no luck. His dad made a several good products for us.


Add a Message


This is a private posting area. Only registered users and moderators may post messages here.
Username:  
Password:

Topics Last Day Last Week Tree View    Getting Started Formatting Troubleshooting Program Credits    New Messages Keyword Search Contact Moderators Edit Profile Administration