Spark plug question

Topics Last Day Last Week Tree View    Getting Started Formatting Troubleshooting Program Credits    New Messages Keyword Search Contact Moderators Edit Profile Administration
Model T Ford Forum: Forum 2016: Spark plug question
Top of pagePrevious messageNext messageBottom of page Link to this message  By Steve Addington on Sunday, July 24, 2016 - 12:35 pm:

What is the correct spark plug number for my 24 TT. Mine currently has Motorcraft F11 plugs. I am going to put a set of new plugs in and just need to know if these are the correct ones? Gap set at .035"?? Thanks


Top of pagePrevious messageNext messageBottom of page Link to this message  By Royce in Dallas TX on Sunday, July 24, 2016 - 12:45 pm:

Those Motorcraft plugs are cold and foul easily. Champio X plugs are much hotter and do not foul easily or at all in most cases.

Original used ones can be found on eBay for $3 - $5 if you are patient. They can be disassembled and cleaned for as long as you own them.


Top of pagePrevious messageNext messageBottom of page Link to this message  By Michael Deichmann, Blistrup, Denmark on Sunday, July 24, 2016 - 04:29 pm:

Don't tell my 1922 sedan as it have been driving for 10 years with Motorcraft and I have never had to clean them.....
I believe we previously have agreed that milage varies considerably when it comes to plugs. What may be good on one engine may not be the best for another.


Top of pagePrevious messageNext messageBottom of page Link to this message  By Steve Jelf, Parkerfield KS on Sunday, July 24, 2016 - 05:09 pm:

Royce is correct about champion X plugs being available at reasonable prices if you're patient, as are other antique Model T plugs. A set of new X's will set you back over a hundred bucks, so used is the way to go for those. If you're in a hurry, there's Autolite 3095. Cheap and functional. I'm currently running a set, and so far they're OK.

Here's some reading on the X plugs: http://dauntlessgeezer.com/DG95.html


Top of pagePrevious messageNext messageBottom of page Link to this message  By Troy Todd on Sunday, July 24, 2016 - 07:54 pm:

Thanks for the explanations. I didn't know I had the later plugs in mine.


Add a Message


This is a private posting area. Only registered users and moderators may post messages here.
Username:  
Password:

Topics Last Day Last Week Tree View    Getting Started Formatting Troubleshooting Program Credits    New Messages Keyword Search Contact Moderators Edit Profile Administration