Coil/Points Question

Topics Last Day Last Week Tree View    Getting Started Formatting Troubleshooting Program Credits    New Messages Keyword Search Contact Moderators Edit Profile Administration
Model T Ford Forum: Forum 2016: Coil/Points Question
Top of pagePrevious messageNext messageBottom of page Link to this message  By David Stroud on Sunday, October 02, 2016 - 01:56 am:

I finally got the '25 coupe out today for the first time since early spring. When I got home after taking one of my Grandsons a ride along with MeMaw (he's Three, can't start them too soon) :-), I noticed the points on one of the coils was putting on quite a light show in the dark. I don't have a lid on the box. It was sparking every time it fired. Does that indicate a capacitor going/gone bad? Thanks in advance, Dave


Top of pagePrevious messageNext messageBottom of page Link to this message  By Bill Harper - Keene, NH on Sunday, October 02, 2016 - 02:46 am:

Hi David,

Well, maybe. Has that coil been rebuilt? If not and it still has the original cap then it likely is time for a new one. If it has been rebuilt with the correct cap, it is quite unlikely that it has failed this soon and may only need some adjustment.

You will want to get a lid on the box as it holds the coils down into the box and prevents them from drifting upwards due to vibration. Good luck with your project. Bill


Add a Message


This is a private posting area. Only registered users and moderators may post messages here.
Username:  
Password:

Topics Last Day Last Week Tree View    Getting Started Formatting Troubleshooting Program Credits    New Messages Keyword Search Contact Moderators Edit Profile Administration