Generator advice

Topics Last Day Last Week Tree View    Getting Started Formatting Troubleshooting Program Credits    New Messages Keyword Search Contact Moderators Edit Profile Administration
Model T Ford Forum: Forum 2016: Generator advice
Top of pagePrevious messageNext messageBottom of page Link to this message  By R. S. Cruickshank on Thursday, December 29, 2016 - 07:37 pm:

The generator stopped charging and I took it apart to try and determine the cause. Found it!!. The phonolic (spelling??) brush insulator was broken. All of the dealers who sell the replacement insulator (2) do not mention the five or six rivets that hold one of the brush assemblies and the insulator itself. Do they come with the insulator and if not what does someone use to replace them? Dick C.


Top of pagePrevious messageNext messageBottom of page Link to this message  By Mark Gregush Portland Oregon on Thursday, December 29, 2016 - 09:02 pm:

No The rivets holding the brush holders are part of 2 brush holders.
The ones that are just rivets you can use pop rivets. Before removing the brush holders I drill and tap each of the two per holder for a screw. I asked somewhat the same question some time back, read this;
http://www.mtfca.com/discus/messages/411944/487877.html?1413906869


Add a Message


This is a private posting area. Only registered users and moderators may post messages here.
Username:  
Password:

Topics Last Day Last Week Tree View    Getting Started Formatting Troubleshooting Program Credits    New Messages Keyword Search Contact Moderators Edit Profile Administration