Rim won't fit on carrier

Topics Last Day Last Week Tree View    Getting Started Formatting Troubleshooting Program Credits    New Messages Keyword Search Contact Moderators Edit Profile Administration
Model T Ford Forum: Forum 2017: Rim won't fit on carrier
Top of pagePrevious messageNext messageBottom of page Link to this message  By Ken - Seattle, WA on Wednesday, April 12, 2017 - 11:16 pm:

I (re)added a rim carrier to my 1925 Touring. The lug stud at the bottom isn't lining up quite right. The way the rim sits, the lug stud is about one quarter inch too low. I can't get it on any farther than what is shown in the pictures. Am I mounting the rim wrong, or could the carrier be a bit bent? I've never used a rear carrier before.

The rim is a re-pop from Snyder's. It doesn't seem undersized when I hold it next to the rims that are already on the car.






Top of pagePrevious messageNext messageBottom of page Link to this message  By Charles Weisgerber- Vancouver WA. on Wednesday, April 12, 2017 - 11:50 pm:

Ken this is what you need. https://www.modeltford.com/item/2849D.aspx

Rotate the wheel 1/8th turn. The clamp that you need will then clamp onto the rim secured by a nut.


Top of pagePrevious messageNext messageBottom of page Link to this message  By Ken - Seattle, WA on Thursday, April 13, 2017 - 12:26 am:

Simple enough! It came with a clamp, but I assumed the stud threaded through the eyelet before the clamp was attached.

Thanks for the help!


Add a Message


This is a private posting area. Only registered users and moderators may post messages here.
Username:  
Password:

Topics Last Day Last Week Tree View    Getting Started Formatting Troubleshooting Program Credits    New Messages Keyword Search Contact Moderators Edit Profile Administration