Turbo 400 hub

Topics Last Day Last Week Tree View    Getting Started Formatting Troubleshooting Program Credits    New Messages Keyword Search Contact Moderators Edit Profile Administration
Model T Ford Forum: Forum 2017: Turbo 400 hub
Top of pagePrevious messageNext messageBottom of page Link to this message  By Erick Keenan - Vineland NJ 08360 on Saturday, April 22, 2017 - 07:22 pm:

Hi, Has anybody had a problem with the turbo 400 hub bore diameter? I just got one and it will not fit the shaft like the ford one; it seems that its about .004" too small. Thank you.


Top of pagePrevious messageNext messageBottom of page Link to this message  By Mark Gregush Portland Oregon on Saturday, April 22, 2017 - 07:41 pm:

The hub is a press fit. Check the shaft for burrs etc that might be giving a false reading, also recheck in more then one place and if you have them use a micrometer rather then slide calipers.


Top of pagePrevious messageNext messageBottom of page Link to this message  By Kohnke Rebabbitting, Clare, Iowa on Saturday, April 22, 2017 - 09:58 pm:

The fit should not be over .0001-00, at .002-00 you will skin the shaft. It should work fine at .000-00.

.003-00 and .004-00, your going to wreck something.

Just so it isn't loose.

Herm.


Top of pagePrevious messageNext messageBottom of page Link to this message  By Brad Marble on Sunday, April 23, 2017 - 03:34 pm:

Erick: Yes I have had the same problem,If your measurements are accurate, send it back, a 0.001 inch interference is all that is usable. Brad from N.H.


Add a Message


This is a private posting area. Only registered users and moderators may post messages here.
Username:  
Password:

Topics Last Day Last Week Tree View    Getting Started Formatting Troubleshooting Program Credits    New Messages Keyword Search Contact Moderators Edit Profile Administration