Thanks, Joe Bell!!

Topics Last Day Last Week Tree View    Getting Started Formatting Troubleshooting Program Credits    New Messages Keyword Search Contact Moderators Edit Profile Administration
Model T Ford Forum: Forum 2017: Thanks, Joe Bell!!
Top of pagePrevious messageNext messageBottom of page Link to this message  By Dennis Hoshield; Oak Park MI on Saturday, July 08, 2017 - 09:51 pm:

Thanks to Joe Bell, I now have a working rebuilt engine! Mine split a head, and after taking it apart, and having the major components magnafluxed, the block had several cracks as well. Decided to just buy a rebuilt rather than attempting muself.... and glad I did. Joe ran it and started it a few times when O picked it up, so I know all was in order. No haopoes, though, after I got it home, installed in it's 'New' chassis, and got all my components re-attached.... as it wouldn't start. Found rust in the carburator . :-( so... was time to rebuild THAT!

I Drilled out the airway plugs, and got everything cleaned back up, re-plugged, and replaced the rubber tip needle and seat, with an old type I had. THEN she took eight off!

I had out CLR mix in the radiator and flushed then put another mix in, after I mounted the radiator back on, and let it run for about 20 min (once I got it running!).... I'll run some more tomorrow, drain rinse and flush, and run straight water in it, unroll I pull it again to have it looked at, as it leaks enough to be bothersome.

In any case... I should have ab'runner' tomorrow, after I get neutral, brakes, etc, adjusted back up!


Add a Message


This is a private posting area. Only registered users and moderators may post messages here.
Username:  
Password:

Topics Last Day Last Week Tree View    Getting Started Formatting Troubleshooting Program Credits    New Messages Keyword Search Contact Moderators Edit Profile Administration