Fine bronze particles in Ruckstell axle oil.

Topics Last Day Last Week Tree View    Getting Started Formatting Troubleshooting Program Credits    New Messages Keyword Search Contact Moderators Edit Profile Administration
Model T Ford Forum: Forum 2017: Fine bronze particles in Ruckstell axle oil.
Top of pagePrevious messageNext messageBottom of page Link to this message  By Bob Doris, AZ on Saturday, August 19, 2017 - 06:54 pm:

Recently installed a rebuilt Ruckstell axle in my 26 roadster and after approx. 60 miles I checked the oil and found fine bronze particles suspended in the oil. (using 85w - 140w) Should I be concerned? Recommendations?

Enlarged photo shows minute bronze particles in oil.


Top of pagePrevious messageNext messageBottom of page Link to this message  By Mark Strange - Hillsboro, MO on Saturday, August 19, 2017 - 07:23 pm:

If it were me, and the axle runs quiet and shifts fine, I would change the fluid and check it again in another 60 miles. :-)


Top of pagePrevious messageNext messageBottom of page Link to this message  By Bob Doris, AZ on Saturday, August 19, 2017 - 07:29 pm:

Ruckstell does run quiet and shifts fine. No unusual noises. Center housing gets slightly warm after a drive.


Add a Message


This is a private posting area. Only registered users and moderators may post messages here.
Username:  
Password:

Topics Last Day Last Week Tree View    Getting Started Formatting Troubleshooting Program Credits    New Messages Keyword Search Contact Moderators Edit Profile Administration