Am I missing a spring?

Topics Last Day Last Week Tree View    Getting Started Formatting Troubleshooting Program Credits    New Messages Keyword Search Contact Moderators Edit Profile Administration
Model T Ford Forum: Forum 2018: Am I missing a spring?
Top of pagePrevious messageNext messageBottom of page Link to this message  By Steve Bourgeois on Sunday, July 29, 2018 - 06:14 pm:

I was under the car and this seems to indicate that I am.


Top of pagePrevious messageNext messageBottom of page Link to this message  By Rich Bingham, Blackfoot, Idaho on Sunday, July 29, 2018 - 06:18 pm:

Six leaves showing - I think the rear spring needs eight or nine ?


Top of pagePrevious messageNext messageBottom of page Link to this message  By Allan Bennett - Australia on Sunday, July 29, 2018 - 08:48 pm:

Steve, the frame is a later 26-7 going on the lip on the rear cross member. The number of leaves in a rear spring does depend on the body fitted. Heavier sedans had extra leaves. The spacings on the end of the leaves in your spring are consistent, so there may not be missing leaves below the spring clip. It may just be that incorrect spring clips have been used.

Hope this helps.
Allan from down under.


Top of pagePrevious messageNext messageBottom of page Link to this message  By David Menzies on Monday, July 30, 2018 - 12:17 am:

I think 8 leaves is the norm, sometimes 9 for heavier loads. there was an accessory 10 leaves for very rough roads


Top of pagePrevious messageNext messageBottom of page Link to this message  By Allan Bennett - Australia on Monday, July 30, 2018 - 03:28 am:

David's photo shows the top two single curve leaves not shown in Steve's post. If he has them up in the frame cross member, then the spring is likely correct and the clips are not.

Allan from down under.


Top of pagePrevious messageNext messageBottom of page Link to this message  By Larry Smith, Lomita, California on Monday, July 30, 2018 - 10:34 am:

Ford offered a six? leaf rear spring for the roadsters in 1925. They had to have a special bar across the clamp to take up the gap. I've seen those, but never have seen a factory spring.


Add a Message


This is a private posting area. Only registered users and moderators may post messages here.
Username:  
Password:

Topics Last Day Last Week Tree View    Getting Started Formatting Troubleshooting Program Credits    New Messages Keyword Search Contact Moderators Edit Profile Administration