I took a squirrel for a ride!

Posts that have nothing to do with the Model T. You can post here or OT posts will be moved here.
Forum rules
If you need help logging in, or have question about how something works, use the Support forum located here Support Forum
Complete set of Forum Rules Forum Rules
User avatar

Topic author
Matt in California
Posts: 393
Joined: Sun Jan 06, 2019 5:42 pm
First Name: Matt
Last Name: G
Location: California
MTFCA Number: 30697

I took a squirrel for a ride!

Post by Matt in California » Sun Mar 31, 2019 1:26 am

Yesterday I worked a bit late,everyone else left at 5:00 promptly, and was the last car in the parking lot. As I walked up to my car I thought I saw a cat or squirrel. I looked under the car nothing. So I lifted the hood and sure enough I spotted a squirrel. It ran and hide, but I didn't seem to run away from the car. So I just started up the car thinking if it was under the car it would run away.

I drove home and mentioned it to my family. We went outside and were surprised to see a squirrel who seemed to be in the state of shock with it's head wedged between the fender and radiator! It's head was facing forward, likely to get fresh air on the drive!

I decided to use a hose with the plan of scaring it away. But all that did was cause it to run around my engine and then hide up in the fender. This morning when I looked for it, it seemed to be gone.

What is the moral to the story? Don't work late on Friday:)


Wayne Sheldon
Posts: 1622
Joined: Sun Jan 06, 2019 3:13 pm
First Name: Wayne
Last Name: Sheldon
Location: Grass Valley Califunny, USA
Board Member Since: 2005

Re: I took a squirrel for a ride!

Post by Wayne Sheldon » Sun Mar 31, 2019 3:51 am

I know a lot of people hate those things, and for some good reasons. But we like them. Glad he made the trip okay. If he can find his way back home I can imagine the tale he will tell his friends!
Thanks for the chuckle!

User avatar

Marv K
Posts: 141
Joined: Sun Jan 06, 2019 8:44 pm
First Name: Marv
Last Name: Konrad
Location: Green Bay area
Board Member Since: 2010

Re: I took a squirrel for a ride!

Post by Marv K » Mon Apr 01, 2019 1:14 am

-Matt-
You're fortunate it wasn't a 'flying squirrel'! (If you've never seen one, send me your email, and I'll send pics.) I haven't figured out 'how to post onto a thread, as yet.
"Let's Figgur it owt!" Just fix it (right), and make it work.....
Aah-OO-Gah! (and), "Happy T-ing!"

Post Reply Previous topicNext topic